WordPress has announced that it will no longer provide security support for older installations. This means that business owners who have not upgraded to the latest version of WordPress will be vulnerable to attacks. 

The current version is at 6.0.2, but there is still a small percentage of users who prefer the themes and plugins associated with older versions. Since such a small amount of WordPress users aren't up-to-date, most site owners won't be impacted by security not supporting the older variants of the site.

Key Takeaways:

  • For older versions of WordPress, the publishers will be notified of the latest available updates and that their version has stopped being updated.
  • Updates will continue to be provided from version 4.01, which is an older version to the current 6.02 version.
  • The security updates will end on December 1, 2022. Hardening updates will not be backported to older versions, such as 4.01 and it is still recommended to update to 6.02.

“The reason for dropping security support is that the WordPress core development team can better focus on updating the latest versions without the burden of keeping older versions up to date.”

Read more: https://www.searchenginejournal.com/wordpress-drops-security-support-for-older-installations/464983/